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INTRODUCTION 
 
 The tests contained in this document are organized in order to simplify the identification of information 
related to a test, and to facilitate in the actual testing process.  Tests are separated into groups, primarily in order to 
reduce setup time in the lab environment, however the different groups typically also tend to focus on specific 
aspects of device functionality. 
 
 The test definitions themselves are intended to provide a high-level description of the motivation, 
resources, procedures, and methodologies specific to each test.  Formally, each test description contains the 
following sections: 
 
 
Purpose 
 The purpose is a brief statement outlining what the test attempts to achieve.  The test is written at the 
functional level.  
 
References 
 This section specifies all reference material external to the test suite, including the specific subclauses 
references for the test in question, and any other references that might be helpful in understanding the test 
methodology and/or test results.  External sources are always referenced by a bracketed number (e.g., [1]) when 
mentioned in the test description.  Any other references in the test description that are not indicated in this manner 
refer to elements within the test suite document itself (e.g., “Appendix 6.A”, or “Table 6.1.1-1”) 
 
Resource Requirements 
 The requirements section specifies the test hardware and/or software needed to perform the test.  This is 
generally expressed in terms of minimum requirements, however in some cases specific equipment 
manufacturer/model information may be provided. 
 
Last Modification 
 This specifies the date of the last modification to this test. 
 
Discussion 
 The discussion covers the assumptions made in the design or implementation of the test, as well as known 
limitations.  Other items specific to the test are covered here as well. 
 
Test Setup 
 The setup section describes the initial configuration of the test environment.  Small changes in the 
configuration should not be included here, and are generally covered in the test procedure section (next). 
 
Procedure 
 The procedure section of the test description contains the systematic instructions for carrying out the test.  
It provides a cookbook approach to testing, and may be interspersed with observable results. 
 
Observable Results 
 This section lists the specific observables that can be examined by the tester in order to verify that the DUT 
is operating properly.  When multiple values for an observable are possible, this section provides a short discussion 
on how to interpret them.  The determination of a pass or fail outcome for a particular test is generally based on the 
successful (or unsuccessful) detection of a specific observable. 
 
Possible Problems 
 This section contains a description of known issues with the test procedure, which may affect test results in 
certain situations.  It may also refer the reader to test suite appendices and/or other external sources that may provide 
more detail regarding these issues. 
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GROUP 2: PHY TRANSMITTER REQUIREMENTS 
 
Overview: 

This group of tests verifies the Phy Transmitter Requirements, as defined in Section 2.11 
of the SATA Interoperability Unified Test Document, v1.0 (which references the SATA 
Standard, v2.5). 
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Test TX-01  - Pair Differential Impedance 
 
Purpose:  To verify that the Pair Differential Impedance of the DUT’s transmitter is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 21 – Transmitter Specifications 
[2] Ibid, 7.2.2.2.1 – TX Pair Differential Impedance (Gen1i) 
[3] Ibid, 7.4.22 – TDR Differential Impedance (Gen1i/Gen1m) 
[4] SATA Interoperability Program Unified Test Document, Section 2.11.1 – Pair Differential Impedance 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 2.2) 
 
Discussion:   

Reference [1] specifies the Transmitter Specification conformance limits for SATA devices.  This 
specification includes conformance limits for the Pair Differential Impedance.  Reference [2] provides the definition 
of this term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test.  
Reference [4] provides additional requirements for performing this test for the purposes of the SATA Logo program. 
 

 
Test Setup:  

See Appendix A 
 
 
 
Test Procedure: 

Assuming the initial setup/cal procedures in Appendix B have been performed, the measurement for this 
test is as follows: 

 
1 Ensure that the DUT is powered on, and has completed an initial OOB sequence through the device 

COMWAKE in order to allow device calibration to occur.  
2 Connect the TDR cables to J16 (TP+) and J15 (TP-) of the Agilent SAS/SATA Drive Fixture. 
3 Adjust the scope timebase and delay to display the Pair Differential Impedance on the screen. 
4 Enable TDR Peeling on the Response 1 trace by selecting MEASURE->Math from the top menu bar, 

then under the Function 3 tab, check the ‘Function 3 Display On’ box, and select ‘TDR Peeling’ and 
‘Response 1’ under the Operator and Source 1 pulldown menus, respectively. 

5 Using the cursors on the Function 3 response, determine the time point of the last major capacitive dip. 
6 Record the impedance value at the point occurring 2ns after the last major capacitive dip (See Figure 1, 

next page, for sample measurement.) 
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Figure 1: Sample Impedance Measurement at time point 2ns after last major dip 

 
 
Observable Results: 

The measured impedance value shall be between 85 and 115 ohms for 1.5G devices, as well as 3.0G 
devices operating in 1.5G mode. 
 
Possible Problems:   

None. 
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Test TX-02  - Single-Ended Impedance 
 
Purpose:  To verify that the Single-Ended Impedance of the DUT’s transmitter is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 21 – Transmitter Specifications 
[2] Ibid, 7.2.2.2.2 – TX Single-Ended Impedance (Gen1i) 
[3] Ibid, 7.4.23 – TDR Single-Ended Impedance (Gen1i/Gen1m) 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitter Specification conformance limits for SATA devices.  This 
specification includes conformance limits for the Single-Ended Impedance.  Reference [2] provides the definition of 
this term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
 
Test Setup:  
 See Appendix A 
 
Test Procedure: 

Assuming the initial setup/cal procedures in Appendix B have been performed, the measurement for this 
test is as follows: 

 
1 Ensure that the DUT is powered on, and has completed an initial OOB sequence through the device 

COMWAKE in order to allow device calibration to occur.  
2 Connect the TDR cables to J16 (TP+) and J15 (TP-) of the Agilent SAS/SATA Drive Fixture. 
3 Adjust the scope timebase and delay to display the Pair Differential Impedance on the screen. 
4 Go to the TDR Setup screen and choose Common Mode Stimulus.  Close the Setup screen. 
5 Open the Response screen and choose Response 1 to be Individual and Response 2 to be Individual. 
6 Enable TDR Peeling on the Response 1 trace by selecting MEASURE->Math from the top menu bar, 

then under the Function 3 tab, check the ‘Function 3 Display On’ box, and select ‘TDR Peeling’ and 
‘Response 1’ under the Operator and Source 1 pulldown menus, respectively. 

7 Enable TDR Peeling on the Response 2 trace by selecting MEASURE->Math from the top menu bar, 
then under the Function 4 tab, check the ‘Function 4 Display On’ box, and select ‘TDR Peeling’ and 
‘Response 2’ under the Operator and Source 1 pulldown menus, respectively. 

8 Using the min/max measurement functions on the Measure tab on the left side of the screen, measure 
and record the maximum and minimum values of the Pair Single-Ended Impedance for the Function 3 
and Function 4 responses. 

 
 
Observable Results: 

The measured impedance value shall be greater than 40 ohms for 1.5G devices, as well as 3.0G devices 
operating in 1.5G mode. 
 
Possible Problems:   

None 
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Test TX-03  - Differential Mode Return Loss 
 
Purpose:  To verify that the Differential Mode Return Loss of the DUT’s transmitter is within the conformance 
limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 21 – Transmitter Specifications 
[2] Ibid, 7.2.2.2.3 – TX Differential Mode Return Loss (Gen2i, Gen2m) 
[3] Ibid, 7.4.10 – Return Loss and Impedance Balance 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitter Specification conformance limits for SATA devices.  This 
specification includes conformance limits for the Differential Mode Return Loss.  Reference [2] provides the 
definition of this term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for 
this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

Assuming the initial setup/cal procedures in Appendix B have been performed, the measurement for this 
test is as follows: 

 
1 Ensure that the DUT is powered on, and has completed an initial OOB sequence through the device 

COMWAKE in order to allow device calibration to occur.  
2 Connect the TDR cables to J16 (TP+) and J15 (TP-) of the Agilent SAS/SATA Drive Fixture. 
3 Adjust the scope timebase and delay to display the Pair Differential Impedance on the screen. 
4 Display the S-Parameters for the Differential response by selecting the “S-Param” pulldown in the 

upper right corner of the display.  This is effectively the Differential Return Loss. 
5 Using the cursors, verify that the Return Loss meets or exceeds the values shown in the table below. 

 
Observable Results: 

The TX Differential Mode Return Loss shall be greater than the minimum limits specified in reference [1] 
for 3.0G devices.  For convenience, the values are reproduced below. 

 
Frequency Range Minimum Limit (3.0G) 

150-300 MHz 14 dB 
300-600 MHz 8 dB 

600-1200 MHz 6 dB 
1200-2400 MHz 6 dB 
2400-3000 MHz 3 dB 
3000-5000 MHz 1 dB 

 
Possible Problems:   

None. 
 



Serial ATA Logo Group 

 
 
Serial ATA Logo Group 11 SATA TxRx MOI for Agilent 86100C 
  

Test TX-04  - Common Mode Return Loss 
 
Purpose:  To verify that the Common Mode Return Loss of the DUT’s transmitter is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 21 – Transmitter Specifications 
[2] Ibid, 7.2.2.2.4 – TX Common Mode Return Loss (Gen2i, Gen2m) 
[3] Ibid, 7.4.10 – Return Loss and Impedance Balance 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitter Specification conformance limits for SATA devices.  This 
specification includes conformance limits for the Common Mode Return Loss.  Reference [2] provides the definition 
of this term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

Assuming the initial setup/cal procedures in Appendix B have been performed, the measurement for this 
test is as follows: 

 
1 Ensure that the DUT is powered on, and has completed an initial OOB sequence through the device 

COMWAKE in order to allow device calibration to occur.  
2 Connect the TDR cables to J16 (TP+) and J15 (TP-) of the Agilent SAS/SATA Drive Fixture. 
3 Adjust the scope timebase and delay to display the Pair Common Mode Impedance on the screen. 
4 Display the S-Parameters for the response by selecting the “S-Param” pulldown in the upper right 

corner of the display.  This is effectively the Return Loss. 
5 Using the cursors, verify that the Return Loss meets or exceeds the values shown in the table below. 

 
Observable Results: 

The TX Common Mode Return Loss shall be greater than the minimum limits specified in reference [1] for 
3.0G devices.  For convenience, the values are reproduced below. 

 
Frequency Range Minimum Limit (3.0G) 

150-300 MHz 8 dB 
300-600 MHz 5 dB 
600-1200 MHz 2 dB 

1200-2400 MHz 2 dB 
2400-3000 MHz 2 dB 
3000-5000 MHz 1 dB 

 
 
Possible Problems:   

None. 
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Test TX-05  - Impedance Balance 
 
Purpose:  To verify that the Impedance Balance of the DUT’s transmitter is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 21 – Transmitter Specifications 
[2] Ibid, 7.2.2.2.5 – TX Impedance Balance (Gen2i, Gen2m) 
[3] Ibid, 7.4.10 – Return Loss and Impedance Balance 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitter Specification conformance limits for SATA devices.  This 
specification includes conformance limits for the TX Impedance Balance.  Reference [2] provides the definition of 
this term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

Assuming the initial setup/cal procedures in Appendix B have been performed, the measurement for this 
test is as follows: 

 
1 Ensure that the DUT is powered on, and has completed an initial OOB sequence through the device 

COMWAKE in order to allow device calibration to occur. 
2 Connect the TDR cables to J16 (TP+) and J15 (TP-) of the Agilent SAS/SATA Drive Fixture. 
3 Adjust the scope timebase and delay to display the TDC11 response on the screen. 
4 Display the S-Parameters for the response by selecting the “S-Param” pulldown in the upper right 

corner of the display.  This is effectively the Return Loss. 
5 Using the cursors, verify that the Return Loss meets or exceeds the values shown in the table below. 

 
Observable Results: 

The TX Impedance Balance, TDC11, shall be greater than the minimum limits specified in reference [1] for 
3.0G devices.  For convenience, the values are reproduced below. 

 
Frequency Range Minimum Limit (3.0G) 

150-300 MHz 30 dB 
300-600 MHz 20dB 
600-1200 MHz 10 dB 

1200-2400 MHz 10 dB 
2400-3000 MHz 4 dB 
3000-5000 MHz 4 dB 

 
Possible Problems:   

None. 
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GROUP 4: PHY RECEIVER REQUIREMENTS 
 
Overview: 

This group of tests verifies the Phy Receiver Requirements, as defined in Section 2.14 of 
the SATA Interoperability Unified Test Document, v1.0 (which references the SATA Standard, 
v2.5). 
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Test RX-01  - Pair Differential Impedance 
 
Purpose:  To verify that the Pair Differential Impedance of the DUT’s receiver is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 23 – Receiver Specifications 
[2] Ibid, 7.2.2.4.1 
[3] Ibid, 7.4.22 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 2.2) 
 
Discussion:   

Reference [1] specifies the Transmitted Signal conformance limits for SATA devices.  This specification 
includes conformance limits for the RX Pair Differential Impedance.  Reference [2] provides the definition of this 
term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 
 (The procedure for this test is identical to that of test TX-01, with the exception that the TDR cables shall 
be connected to J13 (RP+) and J14 (RP-) of the Agilent SATA Drive Fixture.) 
 
Observable Results: 

The measured impedance value shall be between 85 and 115 ohms for 1.5G devices, as well as 3.0G 
devices operating in 1.5G mode. 
 
Possible Problems:   

None. 
 
 



Serial ATA Logo Group 

 
 
Serial ATA Logo Group 15 SATA TxRx MOI for Agilent 86100C 
  

Test RX-02  - Single-Ended Impedance 
 
Purpose:  To verify that the Single-Ended Impedance of the DUT’s receiver is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 23 – Receiver Specifications 
[2] Ibid, 7.2.2.4.2 
[3] Ibid, 7.4.23 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitted Signal conformance limits for SATA devices.  This specification 
includes conformance limits for the RX Single-Ended Impedance.  Reference [2] provides the definition of this term 
for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

(The procedure for this test is identical to that of test TX-02, with the exception that the TDR cables shall 
be connected to J13 (RP+) and J14 (RP-) of the Agilent SATA Drive Fixture.) 

 
Observable Results: 

The RX Single-Ended Impedance shall be at least 40 Ohms for 1.5Gb/s devices as well as 3.0G devices 
operating in 1.5G mode. 
 
Possible Problems:   

None. 
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Test RX-03 – Differential Mode Return Loss 
 
Purpose:  To verify that the Differential Mode Return Loss of the DUT’s receiver is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 23 – Receiver Specifications 
[2] Ibid, 7.2.2.4.3 
[3] Ibid, 7.4.10 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitted Signal conformance limits for SATA devices.  This specification 
includes conformance limits for the RX Differential Mode Return Loss.  Reference [2] provides the definition of this 
term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

(The procedure for this test is identical to that of test TX-03, with the exception that the TDR cables shall 
be connected to J13 (RP+) and J14 (RP-) of the Agilent SATA Drive Fixture.) 

 
Observable Results: 

The RX Differential Mode Return Loss shall be greater than the minimum limits specified in reference [1] 
for 3.0G devices.  For convenience, the values are reproduced below. 

 
 

Frequency Range Minimum Limit (3.0G) 
150-300 MHz 18 dB 
300-600 MHz 14 dB 

600-1200 MHz 10 dB 
1200-2400 MHz 8 dB 
2400-3000 MHz 3 dB 
3000-5000 MHz 1 dB 

 
 

 
Possible Problems:   

None. 
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Test RX-04 – Common Mode Return Loss 
 
Purpose:  To verify that the Common Mode Return Loss of the DUT’s receiver is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 23 – Receiver Specifications 
[2] Ibid, 7.2.2.4.4 
[3] Ibid, 7.4.10 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitted Signal conformance limits for SATA devices.  This specification 
includes conformance limits for the RX Common Mode Return Loss.  Reference [2] provides the definition of this 
term for the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

(The procedure for this test is identical to that of test TX-04, with the exception that the TDR cables shall 
be connected to J13 (RP+) and J14 (RP-) of the Agilent SATA Drive Fixture.) 

 
Observable Results: 

The RX Common Mode Return Loss shall be greater than the minimum limits specified in reference [1] for 
3.0G devices.  For convenience, the values are reproduced below. 

 
 

Frequency Range Minimum Limit (3.0G) 
150-300 MHz 5 dB 
300-600 MHz 5 dB 

600-1200 MHz 2 dB 
1200-2400 MHz 2 dB 
2400-3000 MHz 2 dB 
3000-5000 MHz 1 dB 

 
 
Possible Problems:   

None. 
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Test RX-05 – Impedance Balance 
 
Purpose:  To verify that the Impedance Balance of the DUT’s receiver is within the conformance limits. 
 
References: 

[1] SATA Standard, 7.2.1, Table 23 – Receiver Specifications 
[2] Ibid, 7.2.2.4.5 
[3] Ibid, 7.4.10 

 
Resource Requirements:  
 See Appendix A 
  
Last Modification:  October 18, 2006 (Version 1.4) 
 
Discussion:   

Reference [1] specifies the Transmitted Signal conformance limits for SATA devices.  This specification 
includes conformance limits for the RX Impedance Balance.  Reference [2] provides the definition of this term for 
the purposes of SATA testing.  Reference [3] defines the measurement requirements for this test. 
 
Test Setup:  

See Appendix A 
 
Test Procedure: 

(The procedure for this test is identical to that of test TX-05, with the exception that the TDR cables shall 
be connected to J13 (RP+) and J14 (RP-) of the Agilent SATA Drive Fixture.) 

 
Observable Results: 

The RX Impedance Balance shall be greater than the minimum limits specified in reference [1] for 3.0G 
devices.  For convenience, the values are reproduced below. 

 
 

Frequency Range Minimum Limit (3.0G) 
150-300 MHz 30 dB 
300-600 MHz 30 dB 

600-1200 MHz 20 dB 
1200-2400 MHz 10 dB 
2400-3000 MHz 4 dB 
3000-5000 MHz 4 dB 

 
 
Possible Problems:   

None. 
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APPENDICES 
 
Overview: 

Test suite appendices are intended to provide additional low-level technical detail 
pertinent to specific tests contained in this test suite.  These appendices often cover topics that 
are outside of the scope of the standard, and are specific to the methodologies used for 
performing the measurements in this test suite.  Appendix topics may also include discussion 
regarding a specific interpretation of the standard (for the purposes of this test suite), for cases 
where a particular specification may appear unclear or otherwise open to multiple interpretations.  
 
Scope: 

Test suite appendices are considered informative supplements, and pertain solely to the 
test definitions and procedures contained in this test suite. 
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Appendix A – Resource Requirements and Test Setup 
 
Purpose:  To define the hardware/software requirements and basic test setup used for all tests in this test suite. 
 
References: 

None. 
 
Last Modification:  July 18, 2006 (Version 1.2) 
 
Discussion: 
 
A.1 - Introduction  
 

Custom SATA test fixtures are required for performing the physical layer tests covered in this document.  
The purpose of this appendix is to present a reference implementation of these test fixtures, to specify the basic test 
equipment used for performing the tests contained in this document, and to define the basic test setup which is used 
for all tests.   
 
A.2 - Equipment  
 
 The list below summarizes the measurement equipment required for performing the tests contained in this 
document. 

• 1-Agilent 86100C DCA-J with options 001, 200 and 202 
• 1-Agilent 54754A TDR module 
• 2-high quality SMA cables 
• 1-Agilent SAS Drive X2 Primary Test Fixture, Agilent P/N N5421-26401 
• 1 – 3.5 mm Connector torque wrench 
• 1 – Agilent N1024A Cal Kit 

 
A.3- Fixture Implementations 
 

 
Figure A-1:  Agilent SAS/SATA Drive Test Fixture 
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Figure A-2:  Agilent SAS/SATA Drive Test Fixture (Reverse) 

 
 
Above is a picture of the Agilent SAS Primary X2 Drive Fixture, which converts a SAS/SATA connector 

to 4 SMAs in order to make signal quality measurements. 
 
A.4- Test Setup 
 
 Shown below is the basic setup used for all tests in this test suite.  TDR Channels 1 and 2 are connected to 
either the TX or RX pair of the DUT (for tests TX-01/05 or RX-01/05, respectively), while the DUT is powered 
using a standard PC power supply connected to the Agilent test fixture. 
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Figure A-3:  General TDR Test Setup 
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Appendix B – Agilent 86100C TDR - Setup and Calibration Procedure 
 
Purpose:  To define the initial setup and calibration procedure which applies to all tests in this test suite. 
 
References: 

None. 
 
Last Modification:  January 25, 2006 (Version 1.0) 
 
Discussion: 
 
B.1 - Introduction  
 

Before performing any of the tests in this suite, the Agilent 86100C must be initialized and calibrated 
specifically for the requirements of the tests that are to be performed.  This appendix covers the initialization 
procedure, as well as the calibration steps that will prepare the instrument for performing the tests. 

 
Note that the procedure in this appendix must only be performed once, before performing any/all of the 

tests defined in this document.  (It will typically be performed prior to performing the TX-01 test.) 
 
 
B.2 – Initialization and Calibration Procedure 
 
 
Initialize 86100C: 

• Ensure the DCA-J has been running for at least 1 hour for proper warm-up. 
• Remove all cables from the instrument and press the DEFAULT SETUP button, then the TDR/TDT 

MODE button. 
 
Perform Module Calibration: 

• Using menus, select Calibrate->All Calibrations->Calibrate Left Module, and follow on-screen 
instructions. 

 
Turn down sampling rate: 
Click the TDR Setup button on the left side of the screen, go to Advanced, and select a manual rate of 50kHz.  
(You can leave the TDR Setup window open here, as it’s used in the next step.) 
 
Set up hardware and deskew cables: 

• Connect cables to left module.  Torque properly. 
• Deskew both pairs of cables using the procedure found in the 86100C on-line help:  Help->Contents->S-

>Skew->Differential TDR Skew.  (A modified summary of procedure is included below, as the Agilent 
procedure is somewhat confusing, and I believe contains minor erroneous typos.) 

o With cables connected, click the TDR SETUP button on the left setup bar. 
o Select Common Mode stimulus and Common Mode 1-Port DUT type. 
o Uncheck both measurement boxes, and click DESKEW. 
o Under normal circumstances (1m cables), the markers on screen will be shown on the first incident 

step.  Move them to the second (reflected) step by adjusting the Horizontal Position knob to bring 
the reflected step to the middle of the display. 

o The channel with the longer cable will be the one whose step is further to the right side of the 
screen.  If yellow is on the right, CH1 is longer.  Green on right means CH2 is longer.  (Note: This 
procedure assumes the longer cable is on CH2.  If yellow is on the right, swap the cables at this 
point to put the longer on CH2, so green is on the right.) 

o Read the Mean value from the measure bar, which should be a positive value.  Enter half of the 
absolute value of the mean into the Horizontal Skew box for the longer channel 
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o Adjust the TDR Skew values to initial values +10%/-10% for CH1/CH2, and then tweak them to 
make the mean delta time as close to zero as possible.  Somewhere below 500fs should be fine.  
(Note, the Agilent help text says use a positive percentage value for the longer cable, but their 
picture shows the opposite.  I believe the picture is correct, and the values shown here are 
consistent with the picture.  Also note not it is unclear whether the values must be adjusted 
symmetrically.  UNH uses symmetrical values, but the Agilent help shows otherwise.  Thirdly, 
note that the default horizontal settings are somewhat coarse, and if you zoom in on the step a bit 
by turning the Horizontal Scale knob right 2-3 clicks and re-centering the display, you can get a 
much more accurate value.) 

o Close the Differential TDR Skew window. 
• Set up Differential TDR: 

o Back on the TDR/TDT Setup window, select Differential Stimulus Mode, and check the 
SDD11 response box.  Close the window. 

 
Perform TDR Calibration: 

• Touch the Calibration Wizard button on the left setup bar, which will guide you through the TDR 
calibration process. 

• The second step of the cal will ask you to “Adjust the timebase so that the entire response of the DUT is 
visible”.  Set the Horizontal Scale to 1.000ns/div.  Note that the excessively-long timebase setting is 
required in order to get adequate resolution in the frequency domain for the Return Loss measurements. 

• Doublecheck that the spike in the response (corresponding to the open at the end of the cables) is located 
within the first graticule from the left side of the screen.  (It should be this way by default, as long as the 
horizontal position knob wasn’t touched.) 

• Finish the rest of the cal procedure.  
 

Adjust TDR Risetime for Proper Test Value (100ps, 20-80%): 
• Connect the cables to the Agilent SAS/SATA fixture (either port will do.) 
• Vertically center the differential response to appear fully on-screen by clicking the Response button, and 

under Response 1 enter a manual offset value of 500mV.  Close the Response window. 
• Touch the Measure tab on the left side of the screen and choose Rise Time to measure the rise time of the 

differential stimulus as it exits the fixture. 
• Touch the Setup/info button to the right of the measurement results, choose Configure Meas… and 

choose 20%,50%,80% for the threshold. 
• Go back to the TDR Setup screen (button on left tab) and adjust the Effective Rise Time until the 

measured rise time is 100ps.   Note: UNH uses ~144ps in the risetime window, which yields ~99.5ps at the 
fixture tip. 

• Save the cal under File->Save->TDR/TDT Calibration as Pair A TDR 100.tdr. 
 
Finish config and save instrument setup: 

• Specify Ohms for units by clicking the yellow Channel 1 config button on the lower left corner of the 
display and select Advanced->Ohms.  Repeat for Channel 2. 

• Set the display by clicking the Response button, and set Response 1 to Differential (should already be set), 
and set a manual scale of 50 Ohms/div and 100 Ohms offset. 

• Save the setup under File->Save->Instrument Setup as Pair A set.set. 
 
Note: To reset the instrument to the fully configured and calibrated state prior to any test, first press the DEFAULT 
SETUP button, then recall the Pair A set.set settings file, then recall the Pair A TDR 100.tdr TDR/TDT calibration 
file.   
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Appendix C – Condensed Test Procedure 
 
Purpose:  To define a condensed and combined procedure which covers all tests in this test suite. 
 
References: 

None. 
 
Last Modification:  February 9, 2006 (Version 1.0) 
 
Discussion: 
 
C.1 - Introduction  
 

The standard procedures in this test document are defined for each individual test.  Because there is a large 
degree of similarity and overlap between the tests, it is possible to define a single procedure that covers all of the 
tests with a minimum number of steps, if the separate procedures are combined and re-arranged.  This appendix 
provides such a procedure, to allow all of the tests to be performed in an optimally short time period. 
 
 
C.2 – Test Procedure 
 

1) Perform the initial setup and calibration procedure found in Appendix B. 
2) Upon finishing the setup/cal procedure, the instrument is already set up to do the RX-01 test.  We will do 

this one first.  Connect the DUT.  Verify conformance using cursors.  Save a screen capture to RX-01.jpg, 
and save a copy of the waveform to RX-01.txt in XY verbose format. 

3) Setup for RX-03 is the same as RX-01, so we’ll do that one next.  All you have to do is pull down the S-
Param window to get the SDD11 return loss.  Use the cursors to verify conformance.  Save a screen 
capture to RX-03.jpg, and export the SDD11 data to RX-03.txt using File->Save->S-Parameter 
Touchstone.   

4) Next, we’ll do the Common-Mode Return Loss test (RX-04).  Click the TDR Setup button, pull down to 
Common Mode Stimulus, and click the SCC11 box (uncheck SDC11).  Close the window.  You should 
see the common mode response in green.  Pull down the S-Param tab.  Verify conformance, and save 
screenshot+text data file as you did in the previous test (RX-04.jpg, and RX-04.txt). 

5) Since we are already set up for Common Mode Stimulus, we can do test RX-05, which measures the 
SDC11.  From the previous test, go back to the TDR Setup window and check only the SDC11 box.  Close 
the window and go to the Response window and click the Auto button.  Verify conformance, grab a screen 
capture of the TDC11 waveform as RX-05.jpg, and pull down the S-parameter window and save that data 
to RX-05.txt. 

6) Finally, we’ll do the Single-Ended Impedance test (RX-02).  With the stimulus still set to Common Mode, 
go to Response, and configure Responses 1 and 2 both to Individual.  Turn the cursor 1 front panel button 
on, measure the low points of the two responses, take a screen capture, and save both waveforms 
(Responses 1 and 2) to verbose txt files RX-02p.txt and RX-02n.txt. 

 
Once these steps are complete, all you need to do is repeat steps 2-6 for the TX pair, simply by moving the 
SMA cables to the TX ports on the fixture, and repeating all of the steps above.  Save all of the same files, but 
use TX-xx instead of RX-xx filenames. 
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